Post

2 followers Follow
0
Avatar

starting in 64 bit mode

Hi all - I started working on the Augustus plugin again after a user reported an issue with it.  Now when starting up Geneious from my IDE (NetBeans) I get this warning:

This installation of Geneious isn't correctly configured for 64 bit systems. This could happen if you installed 64 bit Geneious to the same folder as 32 bit Geneious was previously installed to. Please quit and reinstall Geneious to a new location.  If you continue, Geneious may not function correctly.

Is there some trick to starting up Geneious in 64 bit mode, or is it an issue with my IDE or java platform? I'm running NetBeans and Geneious on Mac OS 10.9.5. Thanks!

Michael Thon

Please sign in to leave a comment.

2 comments

0
Avatar

Geneious gives that warning if you're running a 64 bit VM without appropriate VM options. Adding (or modifying) your VM options to include these should fix it:

-XX:+UseConcMarkSweepGC -XX:MaxPermSize=256M

Hilary Miller 0 votes
Comment actions Permalink
0
Avatar

In Eclipse there is a known bug with the dev kit which means all of our vm parameters are ignored and this warning will be displayed no matter what you put in. Not sure if this affects Netbeans but I'm making a note here for others who may visit. We are working on a fix.

Richard Moir 0 votes
Comment actions Permalink