Post

2 followers Follow
0
Avatar

Crash upon setting up Plugin

Good morning,

I was working on a wrapper plugin for DIAMOND (https://github.com/bbuchfink/diamond). I hadn't tried running the plugin yet; I was just setting it up in the wrapper plugin creator. After making some changes and clicking "OK", I received an error. I sent in an error report and restarted as recommended, but then when trying to reopen Geneious, I got a message suggesting that I change the data location. I tried just clicking "OK", but it lead to the same error message as before. I tried restarting the computer as well, with no luck.

Eventually I just reverted to an older version of my Geneious Data folder from before I had started working on the DIAMOND plugin, and now everything's running smoothly (but without that plugin, of course).

I recently made another plugin successfully. The only two things I can think of that were significantly different between that plugin and this one are that in the DIAMOND plugin, I used the "ignore the command line switch" setting for one option, and I also used the "this option needs to be unchecked for these other options to be available" setting for various options. The code is of course very different for both programs, but as I hadn't tried running the DIAMOND plugin yet, I would think the problem lies in the wrapper plugin creator settings, not in the code of the DIAMOND executable.

The pluginWrapper XML for the DIAMOND plugin, as well as screenshots of the error/crash notifications, are attached in the emails I sent about this issue. Please let me know if any other information would be useful.

Chow

Official comment

Avatar

Hi Chow, sorry for the delay in getting back to you.

We have investigated this issue, and it looks like you're setting some 'circular dependencies' with those checkboxes, where each checkbox depends on the other checkboxes, which is something that Geneious can't resolve and thus crashes.
We will try to improve this, the wrapper creator should not allow these circular dependencies in the first place.

In order to solve your issue, you'll have to remove the `pluginWrapper.xml` file (or modify it to remove all these <dependencies>) in order to start Geneious again, and then adjust the plugin.
I would suggest you use a 'Dropdown' option instead of checkboxes, similar to the screenshot below:

The two important settings here:
* Set the 'Name-Value Separator' option to Ignore the command line switch so that `ThisWillBeIgnored` will indeed be ignored
* Leave the Command Line Text for the default value `Fast (default)` empty

Jonas Kuhn
Comment actions Permalink

Please sign in to leave a comment.

1 comment