Post

2 followers Follow
0
Avatar

Missing Columns in Exporter

Hello,

I been trying to export some data into a CSV file using the Geneious exporter API, but I keep running into a strange issue where the column “# Nucleotide Sequences with Quality” sometime shows up and sometimes doesn’t. I’m not sure where it’s coming from since it’s not one of the selectable columns in the document window. Where is this generated and can I set it to always on?

Also, I noticed when I ran it on my Geneious instance vs another persons Geneious instance, they get the column while I do not. Everything is the same with the exception of the other user having a different area to store their files. 

Other Information:
Geneious ver 8.1.2
Windows 7
All users using Geneious on a Citrix server with shared database

Thanks!




questionimg.jpg
David Bour

Please sign in to leave a comment.

7 comments

0
Avatar

The column should be selectable from the document view when the field is present on any of the documents:

Screen_Shot_2016-04-22_at_11.35.28_AM.png

 

And this should relate directly to the presence of the column in your exported file. If one of the documents you are exporting has a value for "# Nucleotide Sequences with Quality" then the column will be in the CSV.

Hope this helps.

I don't think there is a way to force the column on using the existing exporter unfortunately.

Richard Moir 0 votes
Comment actions Permalink
0
Avatar

Maybe you just need to scroll down in the manage columns window to see it? I tested with 8.0.5 so your version shouldn't be the problem.

Richard Moir 0 votes
Comment actions Permalink
0
Avatar

It's strange because I see it in the object, but it doesn't write-out when I'm running the API exporter on my computer versus my partners computer who is using the same version. Is it a difference in the GUI options somewhere itself that's triggering the difference in the export..??




object_file.jpg
David Bour 0 votes
Comment actions Permalink
0
Avatar

Resolved:

I went ahead and created a new directory for my Data Storage Location and re-initiated all of my Geneious settings. The column options were then enabled. It seems like my user settings were corrupted somehow. Is this possibly because I was saving it on a network drive and it was lost along the way? Anyways, thank you for taking the time to help!

Best
David

David Bour 0 votes
Comment actions Permalink
0
Avatar

Ok, good to hear. Geneious has a kind of master list of fields which might have become corrupted.

Richard Moir 0 votes
Comment actions Permalink